Vulnerability Description
@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.
CVSS Score
CRITICAL
Related Weaknesses (CWE)
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/middie/security/advisories/GHSA-5p92-8765-9fv8
FAQ
What is CVE-2026-112712?
CVE-2026-112712 is a vulnerability with a CVSS score of 9.1 (CRITICAL). @fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in ...
How severe is CVE-2026-112712?
CVE-2026-112712 has been rated CRITICAL with a CVSS base score of 9.1/10. This is considered a critical vulnerability requiring immediate attention.
Is there a patch for CVE-2026-112712?
Check the references section above for vendor advisories and patch information. Review vendor security bulletins for remediation guidance.