Vulnerability Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2.
CVSS Score
CRITICAL
Related Weaknesses (CWE)
References
- https://github.com/BerriAI/litellm/commit/1d5fdc87fed66b49e1df8cf7d708ad93249eb7
- https://github.com/BerriAI/litellm/commit/9161d7f9d6073603ba61ee4aa5e2c0ef5b37a8
- https://github.com/BerriAI/litellm/commit/9fa1a641119dd0d4fe43e93622eae5f482ceb6
- https://github.com/BerriAI/litellm/commit/a80eacacee118fbed54e3d98f239d17a63fac8
- https://github.com/BerriAI/litellm/commit/f7cd90f09e9716652b38daec9f0640cdf49d58
- https://github.com/BerriAI/litellm/releases/tag/v1.100.4
- https://github.com/BerriAI/litellm/releases/tag/v1.101.3
- https://github.com/BerriAI/litellm/releases/tag/v1.102.2
- https://github.com/BerriAI/litellm/releases/tag/v1.103.1
- https://github.com/BerriAI/litellm/releases/tag/v1.104.0-rc.2
- https://github.com/BerriAI/litellm/security/advisories/GHSA-7hp6-4w63-5g45
FAQ
What is CVE-2026-114612?
CVE-2026-114612 is a vulnerability with a CVSS score of 9.9 (CRITICAL). LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context...
How severe is CVE-2026-114612?
CVE-2026-114612 has been rated CRITICAL with a CVSS base score of 9.9/10. This is considered a critical vulnerability requiring immediate attention.
Is there a patch for CVE-2026-114612?
Check the references section above for vendor advisories and patch information. Review vendor security bulletins for remediation guidance.