Vulnerability Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
CVSS Score
HIGH
Affected Products
| Vendor | Product | Versions |
|---|---|---|
| Vllm | Vllm | >= 0.30.0, < 0.32.0 |
Related Weaknesses (CWE)
References
- https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d3Patch
- https://github.com/vllm-project/vllm/pull/60022Patch
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0Release Notes
- https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3hPatchVendor Advisory
FAQ
What is CVE-2026-115915?
CVE-2026-115915 is a vulnerability with a CVSS score of 8.1 (HIGH). vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting ...
How severe is CVE-2026-115915?
CVE-2026-115915 has been rated HIGH with a CVSS base score of 8.1/10. Review the CVSS metrics above for detailed severity breakdown.
Is there a patch for CVE-2026-115915?
Check the references section above for vendor advisories and patch information. Affected products include: Vllm Vllm.