NONE · 0

CVE-2026-116593

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Provider...

Vulnerability Description

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime.  An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker. Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.

References

FAQ

What is CVE-2026-116593?

CVE-2026-116593 is a documented vulnerability. Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Provider...

How severe is CVE-2026-116593?

CVSS scoring is not yet available for CVE-2026-116593. Check NVD for updates.

Is there a patch for CVE-2026-116593?

Check the references section above for vendor advisories and patch information. Review vendor security bulletins for remediation guidance.