Vulnerability Description
OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted `cursor` parameter to the `plugins/sql` endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server. This issue is fixed in repository releases 2.19.6.0 and 3.7.0.0.
Related Weaknesses (CWE)
References
- https://github.com/opensearch-project/sql/commit/402a284f1dff3545236480b67f860aa
- https://github.com/opensearch-project/sql/commit/9ab50384d3ad571a14211415fba2f6d
- https://github.com/opensearch-project/sql/pull/5469
- https://github.com/opensearch-project/sql/pull/5572
- https://github.com/opensearch-project/sql/releases/tag/2.19.6.0
- https://github.com/opensearch-project/sql/releases/tag/3.7.0.0
- https://github.com/opensearch-project/sql/security/advisories/GHSA-r8cv-xvqm-4qj
FAQ
What is CVE-2026-63393?
CVE-2026-63393 is a documented vulnerability. OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user wi...
How severe is CVE-2026-63393?
CVSS scoring is not yet available for CVE-2026-63393. Check NVD for updates.
Is there a patch for CVE-2026-63393?
Check the references section above for vendor advisories and patch information. Review vendor security bulletins for remediation guidance.